Ships in list won't load most of the time
#1
It seems to be hit or miss. Trying to load federation ships in the skill planner from the ship selector drop down list just isn't working.

Sometimes it will load the ship but most of the time nothing happens at all. I was trying to load the new Experimental Science Vessel T6 to create a build for it but it won't show up. Then I tried a few T5-U ships and again nothing would load. I tried fleet ships and even shuttles and nothing. I was able to get 1 of the Andorian escorts to load in the planner then another ship, then the Andorian ship wouldn't load again.
#2
I just tried and had none of the described issues. Therefore it is my guess, that the release of Delta Rising caused a need in people to create their new T5-U/T6 builds and thereby maybe producing a load on the server.
#3
I'm getting the same results as TacPaddy, everything seems to be working. Did you try clearing your cache?


#4
(10-15-2014, 11:20 AM)Attilio Wrote: I'm getting the same results as TacPaddy, everything seems to be working. Did you try clearing your cache?

Yes. Still no luck. Using Firefox version 33.0.

What happens is the drop down closes when clicking on a ship but no ship loads at all.

Edit: Hmm.....still hit or miss on whether it loads a ship when selecting it in the drop down menu. I got a Consitution Cruiser and Aeon Timeship to load by accident.

Simply clicking the search box then selecting a ship in the list, with no name in the search box, is what I'm having trouble with. I did find 1 way to get it to work: type in part of the ship name in the search box *then* click the ship in the drop down.

The highlighting of the ship names when you put your mouse over them in the list seems a little off. It's like the highlight doesn't quite lock onto the name and when I click it it just closes the drop down. But after typing in part of a ship name in the search box, the highlighting of ship names seems to lock on a ship name when left clicking it and the ship will load into the skill planner.
#5
Hmm very odd, especially that its just happening now. I haven't changed anything with that code. I'll test it out as soon as I get a chance.


#6
I'm having the exact same problem. Had it late last night and now this morning.
#7
Seems to just be a Firefox issue. I should be able to fix it by the end of the weekend


#8
Let me know if it's working for you now. If not I'll keep digging. Thanks.


#9
Still having this problem.

It seems to stop loading ships after the Fleet Heavy Cruiser Retrofit [T5-U]. After that ship in the list you have to use the workaround of starting to type the ship name in the search box then click it in the list when you see it. Though it has trouble loading ships before this one on the list. Still seems to be hit or miss.

I think I found the problem.

Fleet Heavy Cruiser Retrofit: missing 'Fleet' in the name and has 9 consoles and it is in the list under 'Fleet Ships' as 'Heavy Cruiser Retrofit'. In other words you have 2 copies of the Heavy Cruiser Retrofit and the fleet version is missing. The 2 copies of the ship are probably causing some sort of conflict. Both of them will load in the skill planner though.

Edit: Probably unrelated but the text in the list of the new Starship Traits is misaligned a bit. Starship traits won't select either. The list flashes for a split second and the trait slot remains empty. They seem to have a second text of the name of the traits (for example: the text for 'Demolition Teams' is bold and in a yellowish color and overlapping that is regular non-bolded text of the name). The non-bolded trait name is what flashes when clicking the trait to have it added to the trait slot.
#10
Issue with the starship traits has been fixed. Thanks.

The problem with the ship list has to do with the code, although thanks for pointing out the Heavy Cruiser stuff. One was supposed to be T5U so I fixed that.

Clear your cache and try again. Unfortunately I can't replicated the problem on my laptop, but I did see it on my work computer on Friday. So for now you'll have to be my eyes.




Forum Jump:


Users browsing this thread: 1 Guest(s)
Sponsored Links